Community Home Community B-hyve Indoor Underground Timer LAN DNS port 53 forward on my LAN breaks the B-Hive.

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #5516
    Ferdzee
    Participant

    Symptom blinking Wifi with a ! – does not connect, is offline due to DNS failure.

    LAN DNS port 53 forwarding on my LinkSys WRT-1200C Router to the LAN broke my B-HYve DNS. A repro is to forward port 53 to some IP on your network that has no DNS server. This should not affect the B-HYVE but it does. My guess is the B-HYVE always asks the gateway for DNS lookup. This gets looped back into my network to a dead server. It should be using the DNS IP addresses served by the DHC server per RFC 1533 to go to 8.8.8.8:53 instead.

    RFC 1533 3.8. Domain Name Server Option

    The domain name server option specifies a list of Domain Name System
    (STD 13, RFC 1035 [8]) name servers available to the client. Servers
    SHOULD be listed in order of preference.

    The code for the domain name server option is 6. The minimum length
    for this option is 4 octets, and the length MUST always be a multiple
    of 4.

    History: A few days ago I got a message saying my unit was offline. I could not get it to ever connect again after trying multiple WIFI adapters. It was getting a DHCP address, but no traffic was shown in the routers logs from that IP.

    I run secondary a secondary DYN DNS system on my home network, so port 53 is forwarded from the WAN to an IP on my LAN. My DNS server was offline since a week ago, which caused the failure in the B-HYVE. I deleted this port forward, and the B-Hyve now works. This is not how it is supposed to work – the route for DNS on my network is to 8.8.8.8:53, not to my 192.168.0.100:53 via loopback.

    MAC Address: 44:67:55:03:03:66
    Firmware Version: DEBUG-0010
    Hardware Version: WT25G2-0001
    Linksys WRT-1200AC: Version 1.0.5.187766

    Spread the love!
    #5543
    Ryan
    Participant

    Ferdzee, We thank you for your feedback. If you could please set your route settings to 8.8.8.8 with 8.8.4.4 as a back-up. I’ve also updated your timers firmware version for you. If you have any connection issues after, following these changes please let us know. Thank you!

    Spread the love!
    #5595
    Ferdzee
    Participant

    Thankxx for the update. I always had 8.8.8.8 and 8.8.4.4 there. One of my EP8266 programmers suggested you tell your firmware people to add a try-catch on DNS failure and have it use 8.8.8.8 in the catch before giving up. Do not use the routers IP on the catch. There are a LOT of bad ISP DNS systems out there.

    Fred
    http://www.mitsi.com

    Spread the love!
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Spread the love!